PT-LB10VU Multimedia Projector

PT-LB10VU Multimedia Projector
Notice: Undefined variable: position6 in /home/domains2/public_html/ziggy-marley.com/show.php on line 209

Panasonic PT-AE900U Projector Lamp stops working (intermittent)

I have a PT-AE900U with about 1200hrs on the lamp. It has worked perfectly until rcently (last 3 weeks). Issue: Lamp will not start up and the projector shows blinking red light and lamp light. Temporay resolution: I reseat the lamp (remove and reinstall) and the projector works fine for a day or two then the same issue happens. I have cleaned the air filter so I am sure it is not heat. Ideas: Could it just be the lamp dying off? Why does it work when I reseat? Is there a sensor etc in the projector? Please help.. I am going to buy a new lamp soon I think. But I want to ensure

★ ★ ★ ★ ☆ 4.0 stars

PT-LB10VU Multimedia Projector

Product Troubleshooting for PT-LB10VU Multimedia Projector



Notice: Undefined variable: position5 in /home/domains2/public_html/ziggy-marley.com/show.php on line 238

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Answers :


On the iris unit, mechanism stops moving and needs cleaning and greasing, but for best results must be replaced.
Could be a heat sensor, fan bearing issue..have you listened to the fan speed etc, But I think more along the lines of the lamp needs replacing..each time you resit it is thinking ah a new lamp and then realises hey someone is fooling me and shuts down...this scenario is doing you a favour as typically if it blew and shattered the glass it will inevitablly scratch the mirror and lcd block... and if it does that you might as well toss it in the rubbish or sell on ebay for $50 .. Regards Kevin Andreassend, ICE AV Technology Ltd www.iceav.co.nz [email protected]
Having problems with your PT-LB10VU Multimedia Projector ?

Loading ...

Load time: 0.0207 seconds